1

Closed

Cannot Create GovDev Project - sharepoint feature error

description

Hi,
I have uploaded the GoDEV template both to the offical TFS VM with Service Pack 1 (as it didnt work on my TFS production server either). On both instances TFS wizard failed to create a project due to a sharepoint error below. I am able to create lots of other TFS templates (from codeplex) on the same severs without any issues so this just seems to be related to this template. Any advice on how to solve the issue?
 
2012-08-09T11:23:56 | Module: WSS | Thread: 27 | Uploading file: Process Guidance/Supporting Files/Use Case.htm
2012-08-09T11:23:56 | Module: WSS | Thread: 27 | Activating SharePoint Feature: 0d953ee4-b77d-485b-a43c-f5fbb9367207
2012-08-09T11:24:05 | Module: WSS | Thread: 27 | Activating SharePoint Feature: 1d363a6d-d9ba-4498-ad1a-9874aca5f827
2012-08-09T11:24:05 | Module: WSS | Thread: 27 | Activating SharePoint Feature: 2f1da286-e15f-4b99-9e83-afd81680e20c
---begin Exception entry---
Time: 2012-08-09T11:24:05
Module: WSS
Exception Message: TF250035: A feature for SharePoint Products could not be found with the following ID: 2f1da286-e15f-4b99-9e83-afd81680e20c. Verify that the feature is installed on every server in the SharePoint farm for the following Web application: http://mkielytfs/sites/DefaultCollection/GOVDEV. (type TeamFoundationServerException)
Closed Oct 27, 2013 at 4:17 PM by briancjordan
Please install the SharePoint Solution Package for the required Features.

comments

briancjordan wrote Aug 10, 2012 at 5:34 PM

Mark,

First let me ask if you follwed the instructions under the "Project Portal" folder to install the GovDev For TFS SharePoint solution package and if you are in a farm solution of more than one Web Fron End (WFE) that the solution package has been installed on all of the WFEs? Based on the error message that would appear not to be the case as the GUID for the SharePoint Feature that cannot be located is the GUID for the TfsDashboardGovDevMoss Feature in the GovDev For TFS SharePoint solution package :).

Thanks

Brian

wrote Feb 14, 2013 at 3:53 AM

wrote Oct 27, 2013 at 4:17 PM

lbehseresht wrote Jan 7, 2014 at 9:01 PM

I've downloaded & installed GovDev v1.1 alpha, but I wasn't able to create a project due to errors with SharePoint. I'm using WSS 3.0. Do I need to have MOSS 2007 or better?

Thanks!

briancjordan wrote Jan 8, 2014 at 1:28 PM

In looking over the 2010 1.1 Alpha, I can see why you would have this problem. I did not include the SharePoint solution package that contains the feature(s) that would be installed and activated on the SharePoint server - WSS 3.0, MOSS 2007, SharePoint Foundation 2010 or SharePoint Server 2010. I will need to update this for the 2010 solution. Sorry about that...

Until I do that, the simplest thing is to just grab the GovDev For TFS 2010 v1.0 zip and extract the WSP from that and follow my installation instructions. If you need help with this, let me know by sending a direct email.

Thanks

Brian